Authentication configuration with docker

I am trying to configure 3rd party authentication in a docker deployment of parse-server. After many tests, I have a working configuration of parse-server-example, modifying index.js.
export const config = {
auth: {
keycloak: {
enabled: true,
config: {

}
}
}
};

when I inspect the config object, I find
auth: { keycloak: { enabled: true, config: [Object] } },
which seems ok.

I’d like to make it work with a docker container and I don’t get how to pass the configuration options to parse.

I have tried with environment variables
- PARSE_SERVER_AUTH_PROVIDERS={“keycloak”:{“enabled”:true,“config”:{“hostname”:“keycloakhost”,“realm”:“realm”}}}

and with a config.json :
{

“auth”: {“keycloak”:{“enabled”:true,“config”:{“hostname”:“keycloakhost”,“realm”:“realm”}}}
}

When I inspect the config object in that case, I find an array instead of an object :
auth: [
‘{“keycloak”:{“enabled”:true’,
‘“config”:{“realm”:“realm”’,
‘“hostname”:“keycloakhost”}}}’
],

parse-server --help says :
–auth [auth] Configuration for your authentication providers, as stringified JSON. See Parse Server Guide | Parse

What is the correct way to configure 3rd party auth in config.json or with env vars ? What should be my stringified JSON ?

PS: I have a modified keycloak.js adapter, as the one in parse is buggy, which explains the “hostname” key in “config”.