Cannot update to v2.1.1 - Error with pods and SPM both

I am using Cocoapods and was trying to update iOS SDK to 2.1.1 but kept getting error

[!] CocoaPods could not find compatible versions for pod “Parse”:
In Podfile:
Parse (~> 2.1.1)

None of your spec sources contain a spec satisfying the dependency: Parse (~> 2.1.1).

You have either:

  • mistyped the name or version.
  • not added the source repo that hosts the Podspec to your Podfile.

so i removed from podfil, ran update and tried using SPM but getting error 'Parse/Parse.h' file not found. in bridging header file

How to resolve?

I realised Cocoapods support was removed. How to resolve error to use SPM?

Where do you get the error?

In Bridging-Header.h file.

I moved everything except few frameworks to SPM from cocoapods and removed use_frameworks from podfile.

Do you get that error if you create a fresh new Xcode project and only add the SDK via SPM via the Xcode menu “Add packages…”? If yes; at which step exactly do you see the error?

No. Test project added.Test Project

So the issue only occurs in your custom project, but not in a fresh project?

Yes that is what it seems.

My bad!
No it is not working in fresh project also. I had not added import statements earlier.

Corrected Test Project

@Manuel Any suggestion?

  • Which modules did you select to install? Please send a screenshot.
  • Where do you see the error? Please send a screenshot.
  • Does the issue also occur if you select all module / only the ParseCore module?

I selected FacebookUtilsiOS, ParseObjc, ParseUI

Some screenshots here

i tried selecting all modules but facebookUtilstvOS kept giving compiling error. i Added tvOS in destinations also.

facebook-ios-sdk/FBSDKTVOSKit.xcframework:1:1 While building for iOS, no library for this platform was found in

@Manuel did you get chance to check?