Deployment process failing due to GraphQL

Hi,

We use the Docker hub to automate our deployment process. And since yesterday the new builds started to break in the deployment process without having made any changes to package.json.

The error follows:
[91mERR! node_modules / graphql
npm [0m
[91m ERR! graphql @ “15.3.0” from [email protected]
npm ERR! node_modules / parse-server
npm ERR! [0m
[91m parse-server @ “4.4.0” from the root project
npm ERR! peer graphql @ “^ 14.0.0 || ^ 15.0.0” from @ graphql-tools / links @ 6.2.4
npm ERR! node_modules / @ graphql-tools / links
npm ERR! @ graphql-tools / links @ “6.2.4” from [email protected]
npm ERR! node_modules / parse-server
npm ERR! parse-server @ “4.4.0” from the root project
npm ERR! 3 more (@ graphql-tools / stitch, @ graphql-tools / utils, apollo-server-express)
npm ERR!
npm ERR! Could not resolve dependency:
npm ERR! peer graphql @ “^ 0.10.5 || ^ 0.11.3 || ^ 0.12.0 || ^ 0.13.0 || ^ 14.0.0” from [email protected]
npm ERR! node_modules / apollo-server-express / node_modules / graphql-subscriptions
npm ERR! graphql-subscriptions @ “^ 1.0.0” from [email protected]
npm ERR! node_modules / apollo-server-express
npm ERR! apollo-server-express @ “2.18.2” from [email protected]
npm ERR! node_modules / parse-server
npm ERR! parse-server @ “4.4.0” from the root project
npm ERR!
npm ERR! Fix the upstream dependency conflict, or retry
npm ERR! this command with --force, or --legacy-peer-deps
npm ERR! to accept an incorrect (and potentially broken) dependency resolution.
npm ERR!
npm ERR! See /root/.npm/eresolve-report.txt for a full report.

Could you share your package.json?

@davimacedo
{
“name”: “Server”,
“version”: “1.0.0”,
“description”: “Server”,
“main”: “index.js”,
“license”: “MIT”,
“dependencies”: {
@babel/runtime”: “7.4.5”,
“bcryptjs”: “2.3.0”,
“body-parser”: “1.19.0”,
“commander”: “2.20.0”,
“connect-flash”: “0.1.1”,
“cookie-session”: “2.0.0-beta.3”,
“cors”: “^2.8.5”,
“create-react-class”: “15.6.3”,
“crypto-js”: “^3.1.9-1”,
“csurf”: “1.10.0”,
“dotenv”: “^8.1.0”,
“express”: “^4.17.1”,
“history”: “4.9.0”,
“immutable”: “3.8.1”,
“immutable-devtools”: “0.1.3”,
“js-beautify”: “1.10.0”,
“json-file-plus”: “3.2.0”,
“kerberos”: “~0.0.x”,
“migrate-mongo”: “6.0.1”,
“mocha”: “^6.2.0”,
“moip-sdk-node”: “^1.2.1”,
“node-cache”: “^4.2.0”,
“node-schedule”: “1.2.5”,
“nodemailer”: “^4.4.1”,
“package-json”: “6.1.0”,
“parse”: “^1.8.5”,
“parse-server”: “4.4.0”,
“parse-server-mailgun”: “2.4.15”,
“passport”: “0.4.0”,
“passport-local”: “1.0.0”,
“prismjs”: “1.16.0”,
“prop-types”: “15.7.2”,
“query-string”: “6.5.0”,
“react”: “16.8.6”,
“react-dnd”: “7.4.5”,
“react-dnd-html5-backend”: “7.4.4”,
“react-dom”: “16.8.6”,
“react-helmet”: “5.2.1”,
“react-router”: “4.4.0-beta.8”,
“react-router-dom”: “4.4.0-beta.8”
},
“scripts”: {
“start”: “node index.js”,
“test”: “mocha -b --timeout 10000”
},
“engines”: {
“node”: “12.3.1”
},
“devDependencies”: {
“eslint”: “^6.4.0”,
“eslint-config-airbnb-base”: “^14.0.0”,
“eslint-plugin-import”: “^2.18.2”
}
}

This seems to be a duplicate of your comment on the GitHub issue #6967 where you have been asked to provide more details.

Please avoid cross-posting, as mostly the same people are active on either site (Parse Community Forum, GitHub, StackOverflow). Instead, please pick the most appropriate site to post and if you don’t get a satisfactory answer within reasonable time and you decide to post on another site, please make sure to link the posts with each other.

Hi @Manuel, thanks.

I`ll post more details on github.