Installing parse using docker compose and dashboard blank page

Hi All,

I installed Parse and Parse Dashboard using docker compose. Now when i log in i see 403 error for serverinfo call.

Here is docker compose i used. I am not docker expert but i got docker compose from bitnami’s github and edited it based on what info was provided on github page.

version: '2'
      - 'mongodb_data:/bitnami/mongodb'
      - MONGODB_USERNAME=parsedbuser
      - MONGODB_DATABASE=parsedb
      - MONGODB_PASSWORD=parsedbpassword
      - '1337:1337'
      - 'parse_data:/bitnami/parse'
      - mongodb
      - PARSE_DATABASE_HOST=mongodb
      - PARSE_DATABASE_USER=parsedbuser
      - PARSE_DATABASE_NAME=parsedb
      - PARSE_DATABASE_PASSWORD=parsedbpassword
    image: 'bitnami/parse-dashboard:latest'
      - '4040:4040'
      - 'parse_dashboard_data:/bitnami'
      - parse
    driver: local
    driver: local
    driver: local

IP address for host running docker is “”.

Everthing install fine and runs. When i go to dashboard and login i get blank page and following errors in inspector window.

Any idea’s what i am doing wrong? i am trying to install to play with parse but i only found one article and my docker compose looks similar to his except that my syntax is different coz his was written in 2018. If any of you have installed using docker compose and have it working would love to compare and see what i am doing wrong. Also would love to see what other options i can add to compose i am pretty sure i missed something.

Try to include PARSE_SERVER_APPLICATION_ID=apid in your Parse env vars. Here you can find Parse Server options: GitHub - parse-community/parse-server: API server module for Node/Express

Added parameter as requested. Tried dashboard again still blank page but looks like error has changed.

What’s the status code of the error? Also, can you check if there is any error message in the response tab?

Browser is not showing error code and response is empty. All it says is “Referrer Policy:strict-origin-when-cross-origin”
And in payload its sending

    "_method": "GET",
    "_ApplicationId": "apid",
    "_ClientVersion": "js3.4.1",
    "_MasterKey": "mymasterKey",
    "_InstallationId": "2acf112c-5e14-4629-91c9-1bed19b9251c"

Also add PARSE_SERVER_MASTER_KEY=mymasterKey

its still giving same error. looks like parse doesn’t allow cross domain request?

Maybe something related to bitnami image. They should be able to help you on that.

Try running the dashboard in dev mode by adding command: parse-dashboard --dev to your .yml. You can look at my image as an example:

I remember there’s documentation somewhere that says it should be in dev mode when using docker, but I haven’t had a chance to look for it again.

That didnt work either. :frowning: Does anyone has docker compose for mogodb, parse and parse dashboard that they used and worked successfully. I want one i can run locally i am not using AWS or anything. Just running it on my local Unraid server.

The link I posted in my previous comment uses mongo and can be ran locally (details in the readme). It’s also the one used when developers test out the Parse-Swift SDK, so I know it works. You just clone the parse-swift branch, change directory, and type, docker-compose -f docker-compose.mongo.yml up for mongo or docker-compose up for postgres. You can replace this line with parseplatform/parse-server:latest and this line if you want but it should work out of the box.

I might try that with some other machine. As i am running unraid on my server i just installed docker compose plugin to run docker. Looks like i might need to try some other OS on some machine when i can pull things locally. Hard to do on my main unraid server as it hosts out family media gallery and my pc backups. But i will have to give shot to what you are referring to.

i also want to deploy parse using docker but behind a reverse proxy. All containers starting fine and i can reach the dashboards login page. after login i get also a blank page with some errors in chrome dev tools:

Mixed Content: The page at '<URL>' was loaded over HTTPS, but requested an insecure XMLHttpRequest endpoint '<URL>'. This request has been blocked; the content must be served over HTTPS.

how can i prevent or fix this?
my docker-compose file looks like this:

and i also tryed the
command: parse-dashboard --dev
and the

nothing helps