Local Parse Dashboard - Server not reachable: unable to connect to server

I haven’t used the Parse Dashboard in about 2 months, but at that time, everything was working like it should. Now, however, I’m not able to get Parse Dashboard to connect with either my Local dev server nor either our online dev server or our production server.

Note, I have looked at the other threads referring to the same error, but those did not help me to solve the issue. I have tried adding { masterKeyIps: [‘’, ‘::1’] } to the Parse Server configuration, but it didn’t fix the issue. Actually I tried both [‘’, ‘::1’] and [‘’, ‘::/0’], which I believe are supposed to provide the same configuration. I also tried simply removing the “masterKeyIps” property. Nothing has helped.

Something else I tried was using “” instead of “localhost,” but that didn’t work either.

I’m running a local Heroku server that I start with this command in Terminal: “heroku local -p 5000”. I know the server is running, because both my local website and our applications are connecting to that server, and everything is functional.

I don’t know if this happened after an update to Parse or Parse Server, but something has broken the functionality and I don’t know what to do to debug the problem.

One thing to mention, all the settings are provided in the “parse-dashboard-config.json” file. Here are the contents of that file with redacted sensitive information:

	"apps": [
			"serverURL": "production-server-url",
			"appId": "app-id",
			"masterKey": "production-master-key",
			"appName": "Production"
			"serverURL": "dev-server-url",
			"appId": "app-id",
			"masterKey": "dev-master-key",
			"appName": "QA"
			"serverURL": "http://localhost:5000/parse",
			"appId": "app-id",
			"masterKey": "local-master-key",
			"appName": "Local"

Any help I can get in debugging this issue would be greatly appreciated.

New update for my non-local development server. I was able to at least partially fix the connection issue for this server as well. It turns out you must set the “masterKeyIps” property when configuring your Parse Server, of which I was not aware. So now I can connect my Parse Dashboard to our dev Heroku server, but I now have a different problem.

The only way I can make the connection work is if I provide “::/0” for the possibility of a connection using the IPV6 protocol (you must provide configuration for both IPV4 and IPV6). So I’m providing my real public IPV4 Address as well as “::/0” for the “masterKeyIps” array property like so:

{ masterKeyIps: ['xxx.x.xx.xxx', '::/0'] }

The problem is, even if I change my real IPV4 address for Parse Server, Parse Dashboard is still allowing me to read and write data. For example, let’s say my real IPV4 address is I change the Heroku MASTER_KEY_IPS env var to, and everything still works in Parse Dashboard, which shouldn’t happen since the IP Address I’m making the call from does not match the allowed IP Address in “masterKeyIps.”

I thought I might have a public IPV6 formatted IP Address, but when I check my public IP Address, it tells me my IPV6 address is undefined. In that case, the “::/0” index of the “masterKeyIps” property shouldn’t even be considered, correct?

I have an update for this issue. For the local server, the fix was incredibly simple though a bit confusing. The problem is that after starting parse-dashboard in Terminal, you are told, “The dashboard is now available at”. I was looking through the documentation for Parse Dashboard on GitHub and happened to notice that it said, “After starting the dashboard, you can visit http://localhost:4040 in your browser.” It turns out I was incorrectly loading the dashboard in my browser, which seems incredibly obvious now. I typically “command-click” the URLs in Terminal, so I just missed that it wasn’t “localhost” in the browser’s address bar.

I’m almost certain I was able to use “” in the past to load the dashboard in the browser, so I’m not sure what changed. If you’re not supposed to use that IP Address, then something needs to be updated in the Parse Dashboard module so that address isn’t displayed. The good news is, that part of the problem is fixed.

However, I’m still left with not being able to connect to our Production nor our QA server. I’m not setting the “masterKeyIps” for the ParseServer settings. Is that property required as of Parse Server v. 6.4.0, which is what I’m currently running? I was under the impression that if I didn’t supply that setting, it would simply be disabled and connections from all IP Addresses would be accepted.