MongoDB 4 to 5 Migration - All queries return empty results

I need to migrate our cluster from MongoDB 4 to MongoDB 5.
When using MongoDB 5, our iOS app using Parse 1.9.4 (also tried with 2.7.3) fails to retrieve data from Queries (any collection), task results are empty with no errors. Collections do have _rpem have β€œ*” values.
Tried with parser-server versions β€œ2.7.4” and β€œ5.6.0” with no change, mongodb package version is 6.3.0
Did anyone encountered the same issue?
Thank you for your help,

You could run Parse Server in verbose log mode and look at:

  • what request the server receives
  • what query it’s sending to the DB
  • what the DB sends as response

Thank you for getting back to me.

At the end I could find the issue. Parse configured with default DB from the cluster instead of the good one. Verbose log mode was a good advice anyhow.

I was confused because user Login was successful, even if using the wrong DB.

After upgrading a few node packages, it finally runs fine on Heroku.


@yannisroy Glad you could make it work!