Parse 2.8.4 and mongo 4.4

Hi, hope you are all well.

I have a bit of a complex situation, we have some code still running on 2.8.4 and we have a forced upgrade to 4.4 coming in from mongodb atlas and I was wondering what the compatibility for each version of parse vs mongo version is. I cannot find this information as some of the old migration docs are lost in time, see: parse-server/ at 3.0.0 路 parse-community/parse-server 路 GitHub (if anyone has the actual links to the process would be amazing).

So I was wondering, what minimum version of parse do I need for 4.4 compatibility?
And, is there a version to upgrade the mongodb drivers while keeping parse to the ancient 2.8.4?


The compatible MongoDB versions are listed in the README of each version of the Parse Server repository. The compatibility is derived from which MongoDB versions we are testing Parse Server with before publishing a release. Note that this only refers to the features Parse Server itself is using internally, not the custom MongoDB features you may be using in your code, for example specific aggregation pipeline commands or custom driver options that you may be passing directly to the MongoDB Node.js driver. The minimum currently supported version is Parse Server 5; we do not recommend do upgrade to Parse Server <5 as these versions are not actively maintained anymore.

Hi Manuel, Thank you very much for your kind reply.

Just as a FYI, the MongoDB compatibility table is in the readme since version 5. Any version prior to that has no explicit compatibility with MongoDB listed. I checked each release tag readme.

I will attempt an upgrade to version 5 then. Thanks