Parse Dashboard not working, it was before

I had upgraded to ParseServer 6 and discovered that you can’t reliably whitelist a connection using masterKey (required by Parse Dashboard)
masterKeyIps: [’::/0’],

But now I’ve backed off to 5.5.5 and ParseDashboard still gives me unable to connect to server There are no errors showing at the Parse Server end.
My app can connect using the same URL and credentials?

1 Like

hmmm. Seems https may be the issue.

Error: write EPROTO 4965599960:error:100000f7:SSL routines:OPENSSL_internal:WRONG_VERSION_NUMBER:…/…/…/…/src/third_party/boringssl/src/ssl/

This when I run a CURL. The same CURL with http works just fine. GetSchems (using master key)

curl --location ‘http://fakeheroku:1337/parse/schemas
–header ‘X-Parse-Application-Id: APPID’
–header ‘X-Parse-Master-Key: MASTERKEY’
–header ‘Content-Type: application/json’

Does ParseDashboard use SSL even if the url starts with http and not https?

Clients are running on my Mac. My parse server is running on a Linux VM.

Is my version of Node the issue?
Artemis:scripts chris$ node --version

Its my Linux machine. When I switch to https on the iOS app I get this…
2023-09-06 19:00:42.227428-0700 OurHangouts[16508:40533358] [boringssl] boringssl_context_handle_fatal_alert(1991) [C30.1.1.1:2][0x11b519530] write alert, level: fatal, description: protocol version
2023-09-06 19:00:42.227556-0700 OurHangouts[16508:40533358] [boringssl] boringssl_context_error_print(1981) [C30.1.1.1:2][0x11b519530] Error: 4753268536:error:100000f7:SSL routines:OPENSSL_internal:WRONG_VERSION_NUMBER:/Library/Caches/
I nice mod to this error message would be (got version X, expected version Y). but oh well.
I guess I need to get a more recent version of OpenSSL?

This explains the silent failure.

Fixed it myself. DIdn’t realize ParseDashboard no longer supported http unless on local. Good security mod.

Note: Issue is tracked in The option "masterKeyIps" cannot be disabled · Issue #8421 · parse-community/parse-server · GitHub