Recent problem running on Heroku

Hi guys,

Just a little note for those of you who run parse server on Heroku.

It seems like a recent major release of node (from version 16 to 17) might be causing some issue (we explained a workaround we found at the bottom).

Actually, we suddenly started to have the following issue on Heroku that we’d never experienced before. There was no error message when building, as it showed message at the end,

remote: -----> Build succeeded!
remote: -----> Discovering process types
remote: Procfile declares types → (none)
remote: Default types for buildpack → web
remote: -----> Compressing…


However, it crashed when it tried to run it.

Error [ERR_PACKAGE_PATH_NOT_EXPORTED]: Package subpath ‘./public/extractFiles’ is not defined by “exports” in /app/node_modules/extract-files/package.json


What worked for us for now is to set the “engines” versions for node and npm on package.json to be:

“engines”: {
“node”: “<17”,
“npm”: “8.0.0”


As usual I was surprised too by the well documented and communicated node LTS release schedule :wink:

We had the same error, pinning the app to the current active LTS v16 fixed this as well. I will just wait until the beginning of 2022 when all package maintainers have adopted to v17 and try again in prepration for v18. For production we only use the stable even releases, so we will migrate vom v16 to v18 in 2022.

I recommend keeping an eye on the issues and PRs on the server:

And only using versions listed on the readme until it’s confirmed they pass the test suite:

1 Like

Thanks a lot guys!! :blush: