S3 File Adapter with minIO

Hey guys,

I want to use minio with the s3-adapter, but don’t know how to configure it with docker-compose.

I have following Config:

- PARSE_SERVER_FILES_ADAPTER={"module":"@parse/s3-files-adapter", "options":{"bucket":"parsemedia","directAccess":true,"s3overrides":{"s3ForcePathStyle":true,"endpoint":"http://mydomain.de:9000/","accessKeyId":"accessKey","secretAccessKey":"secretKey"}}}

But it still connects to AWS Servers.

The documentation is not clear about that, but I read that it is possible.

Can you try this? Ä° was using this configuration and it was working

{"module":"@parse/s3-files-adapter", "options":{"bucket":"parsemedia","directAccess":true,"endpoint":"http://mydomain.de:9000/","accessKeyId":"accessKey","secretAccessKey":"secretKey"}}

Edit: I thought this was Minio adapter. You should set baseUrl. otherwise parse server will return default aws endpoint.

Try this:

{"module":"@parse/s3-files-adapter", "options":{"bucket":"parsemedia","directAccess":true,"baseUrlDirect": true,"baseUrl": "http://mydomain.de:9000","s3overrides":{"endpoint":"http://mydomain.de:9000","accessKeyId":"accessKey","secretAccessKey":"secretKey"}}}

Thanks for your answer. When I try to save a ParseFile now it says:

The XML you provided was not well-formed or did not validate against our published schema.

Also when I retrieve an image with following URL:

http://mydomain.de:9000/b272d92fa2b1d9504bbad49ae9b5e0bd_image.jpg

It doesn’t display when I access it through the browser it redirects me to the minio login screen.

It is very sad, that there are no documentation about that. I try minio because the normal file adapter doesn’t support the byte range header, which iOS needs to show a video in an

My bad. You need to add bucket name at the end of the base url.

Your base url must be like this
http://mydomain.de:9000/parsemedia

And you can get your file like this
http://mydomain.de:9000/parsemedia/b272d92fa2b1d9504bbad49ae9b5e0bd_image.jpg

It worked!
Thanks so much! If I can spend you a coffee, just tell me :slight_smile:

Following config for docker-compose:

Note: You need to set the right access policies in the minio interface.