Unable to connect to the Parse API JS SDK Bitnami AWS AMI

I used the Bitnami AWS Parse server stack to spin up a new ec2 instance with Parse server and dashboard along with mongodb preinstalled.

I can log into the Parse dashboard fine, I can add/edit/remove rows/columns/classes just fine.

Problem is, when I try to connect from somewhere else through the JS SDK no matter what I do I get “Unable to connect to the Parse APS”.

I’ve ensured that port 1337 is open in the security group both inbound and outbound.

If I go to ec2-54-202-29-109.us-west-2.compute.amazonaws dot com/parse OR ec2-54-202-29-109.us-west-2.compute.amazonaws dot com:1337/parse I get the same problem. I can’t use SSL as I don’t have a legit domain setup on it yet as I’m just trying to get this setup and working.

I’ve also tried the above using the public IP address instead of the aws domain they give you.

Nothing works, always can’t connect to API.

I’m using the default stuff preconfigured from Bitnami, same appId, same everything, nothing works.

This is all just demo/testing stuff so I don’t really care if people have the following:
ec2-54-202-29-109.us-west-2.compute.amazonaws dot com
ssh user: bitnami
cm-hosting private key

Parse Dashboard
“apps”: [
“serverURL”: “”,
“masterKey”: “cs5VZgLOVklu”,
“appId”: “myappID”,
“appName”: “MyDashboard”
“users”: [
“user”: “user”,
“pass”: “cs5VZgLOVklu”

Parse Config
“appId”: “myappID”,
“masterKey”: “cs5VZgLOVklu”,
“appName”: “parse-server”,
“mountPath”: “/parse”,
“port”: “1337”,
“host”: “”,
“serverURL”: “”,
“databaseURI”: “mongodb://bn_parse:[email protected]:27017/bitnami_parse”


Any ideas? I’ve spent the entire day trying to figure out how to get this to connect and I’m at a loss at this point.

(removed http/https and the period from dot com from everything as I have too many links I guess, kind of a pain in the rear when I’m trying to show actual code here lol)

Since Parse Server is working fine and using this server url (“”), that’s the one you should use on SDK. Do you mind to share the code that you are using to initialize the SDK?

I figured it out, I had to use https, it was a cors issue. did the trick.

Well, onto the next problem.

Setup domain on the server using aws application load balancer and setting an SSL cert on it from certificate manager and nothing I did would get it to work over https or wss.

Changed the domain to point directly to the server and setup an SSL cert with let’s encrypt and still cant get https to work. Only http works.

Probably should setup a new stand alone question for this I suppose. I’ve seen a few other posts about this issue but none seem to actually be resolved.