Why I am not able to download image file form parse server?

Hi I am creating an android app where I had used Parse as an cloud server. I have made user to upload there image file to my parse dashboard Viva app developed by me. but while retriving there file they are unable to find there uploaded image.

While I was investigating these problem I found that my user’s file was uploded successfully to parse server

When I double click on Image.png file and selected Download Option as given in the below Image:

I found following screen on my browser many times:

.

Following is my code for uploading and retriving file from parse server:

Some please help me to get rid of these problem

Probably your parse server address is wrong on configuration. Change your parse address to your server ip.

Edit: you configured your server to localhost(127.0.0.1) . And if you use docker, docker automatically redirects requests to containers. And docker has its own iptables. You should change your server address to your server ip adress.

Quick example. Copy your image url. And change 127.0.0.1 to your server ip. You should see your image

Edit 2: also why are you loading image like that. There is an Android library for this. Use Glide. Just get url from parse file and load that url with glide

You just miss to configure the publicServerUrl on your parse server option :smile:

This option is used by parse to return correct urls

See here : https://parseplatform.org/parse-server/api/master/ParseServerOptions.html

I had tried to change config.json file of my server I got following message:

Can you please help me by showing me how can I onfigured my server to localhost(127.0.0.1) ?

You should change parse server adress not parse-dashboard. But I dont have experience on bitnami parse server or parse in docker. So I cant help you with that

Its parse server option yes, not a dashboard one

How and where should I configure the publicServerUrl option
I had use Aws E2 compute to launch parse server instance and connected instance through Putty software.

Please help me to dissolve these issue,Now it’s feeling quite frustrating I had tried each and every possible measure that are enclosed under my knowledge but still not able to find desired result. Now I am wating for some who can help me to get out of it.

Did you try to edit config.json file?

Yes I had tried to edit but got same message I can’t edit any of the file from server.

Error:
Cannot overwrite remote file’/opt/bitnami/parse/config.json’

These is my config file:

I had tried to edit “serverUrl”:“http://18.220.237.153/parse” to
“serverUrl” : “http://127.0.0.1:1337/parse
but got the following message when I had tried to save my file.

This is correct. Do not change it to localhost. But now its weird. Dashboard should return correct url.

Add this line to your config.json file
"publicServerURL":"http://18.220.237.153/parse"

İf you cant save file, try open file as administrator. Or if you are using linux, run command with sudo.

Hummm may be @davimacedo have a suggestion here…
But be careful, you have shared your mongo db connection and parse master key, don’t forget to change it since their are compromised now . :smiley:

Just to be sure, can you share your parse dashboard configuration, the parseUrl that you use in your Android app, and your parse server config ?

Additionally it seems that you forget the port on the public server url (it seems that you use a direct ip and do not have a proxy) , try to add publicServerUrl :http://18.220.237.153:1337/parse

If it works, you should check you Amazon config, to set up a proxy with https, that redirect to your parse server, to avoid MITM (man in the middle attack). Your data could be intercepted by an hacker with public communication over http.

Change your serverUrl and publicServerUrl to http://ec2-18-220 … /parse/
The URL you set In your Android app

Again it’s same, different things have been tried off but getting no change in it . :pensive: :pensive:

Try using Putty to connect to your virtual machine. Go to the respective directory of config.json file using cd command. Than use sudo vim config.json.
sudo command will provide you root rights to make modifications in the json file.